English port change automaticly (solved))

8 replies
Goto Page
To the start Previous 1 Next To the start
Up
haha1955
User
Offline Off
every time if im restart the server, its change the port automaticly. why? what can i do for fix that? please help me
edited 1×, last 27.11.19 09:13:00 pm
25.11.19 11:54:27 am
Up
Marcell
Super User
Offline Off
You didn't mention what sort of OS you are running, Windows or Linux.

Try using server with the commandline parameter -port 36963

You may also try -realport 36963
25.11.19 01:42:34 pm
Up
Hajt
User
Offline Off
Did you specify sv_hostport in server.cfg? Also check if any other app not using selected UDP port, on linux you can do it typing
sudo ss -ulw
Yooo. We are playing mix matches 5on5 in evening hours on the server CS2D.TK | Mix/Match, you can join us, server password is match. Statistics, leaderboard can be found under the following link.
25.11.19 05:27:54 pm
Up
Goo
User
Offline Off
Give every server it's own separated port, don't let two servers attempt to use the same port or the latter one will randomize it's port.
27.11.19 04:43:48 pm
Up
haha1955
User
Offline Off
@user Goo: @user Marcell: @user Hajt: im using debian 32x bit

look i gived my servers the port 45421,45422,45433 ports like this.

so if im every time restart my server or change map, its change the port automaticly...

and if im typing "sudo ss -lw" its coming this:


state      recv-q send-q     local adress:port     peer adress:port
27.11.19 05:58:03 pm
Up
The Superman
User
Offline Off
Can anyone tell me, what exactly is automaticly.
27.11.19 06:07:55 pm
Up
I somehow had same problem aswell, it was some time before, did every thing in the book, listened to other people advices but nothing helped... It fixed itself in 2 weeks, and in that 2 weeks nobody could connect to my server aswell (im talking about listen server ofcourse). My conclusion was that my internet provider had some issues in that time, bcuz internet was working kinda funky aswell, maybe its same for you, give it some time maybe fixes itself.
When I make map for you feedback is apretiated (even bad one), don't be an asshole and say a litle "thank you".
27.11.19 07:50:48 pm
Up
DC
Admin
Offline Off
Using the command line args -port (and if that doesn't work -realport ) like user Marcell said should help.

You have to make sure that:
• You only run one single server instance with a specific port
• No other server instances are already running somehow in the background

Everything else will definitely lead to problems and unexpected behavior.

Also make sure that no other programs are using the UDP ports you plan to use to host your servers.

In some cases simply using other ports might already be a solution.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
27.11.19 07:54:13 pm
Up
Marcell
Super User
Offline Off
It is resolved now, he wasn't using the -port parameter, so of course the binary just choose a port randomly which were free and open.

Just contacted him on Discord and we managed to make it work.
To the start Previous 1 Next To the start