English Error or Bug charset on server.lua

13 replies
Goto Page
To the start Previous 1 Next To the start
Up
Zinaldess2
User
Offline Off
Hello, I tried to create a server in Linux but I'm getting an error or bug from server.lua that is not loading the lua script.

Look at this.

Code:
1
2
3
4
5
6
7
8
9
----- Server started -----

parsing Lua server script (mp_luaserver = 'server.lua')

LUA ERROR: sys/lua/server.lua:1: unexpected symbol near 'ï'

U.S.G.N.: Sending serverlist ADD-request...

U.S.G.N.: Serverlist entry updated
05.10.17 12:04:10 am
Up
Starkkz
Moderator
Offline Off
Your script?
lol
05.10.17 10:16:29 am
Up
apex2d
User
Offline Off
IMG:https://image.prntscr.com/image/2QP2phApQl_pczLIhdRzUw.png


what is this Symbol wtf
Eat Sleep Conquer Repeat. www.Radeon2D.forumid.net
05.10.17 10:19:35 am
Up
Yates
Reviewer
Offline Off
05.10.17 01:49:31 pm
Up
Zinaldess2
User
Offline Off
user apex2d has written:
IMG:https://image.prntscr.com/image/2QP2phApQl_pczLIhdRzUw.png


what is this Symbol wtf


Yeah, what's that?

@user Yates: How do I remove this from server.lua?
05.10.17 02:07:14 pm
Up
Yates
Reviewer
Offline Off
First you show us your code. Then we hopefully solve your issue.
05.10.17 03:57:36 pm
Up
Borealis
Moderator
Offline Off
The root cause of your error is the wrong encoded file. CS2D only supports ANSI for Lua files, other encoding types such as UTF-8 or UTF-16 will throw an error just prior executing the script.

Change the encoding file to ANSI and you're done.
Running CS2D in ReactOS like a boss | I'll be inactive for a couple of weeks. Sorry.
05.10.17 04:00:35 pm
Up
Hajt
User
Offline Off
@user Borealis: Bullshit. There is no problems with UTF-8 encoding for Lua files in CS2D.
05.10.17 04:05:16 pm
Up
Borealis
Moderator
Offline Off
@user Hajt: Whatever it is, keep your file as ANSI. Simple as that.
Running CS2D in ReactOS like a boss | I'll be inactive for a couple of weeks. Sorry.
05.10.17 04:08:19 pm
Up
Yates
Reviewer
Offline Off
@user Borealis: There's no problem in using UTF-8 and this probably isn't the cause of the OP's problem. No point mentioning to use ANSI if it won't solve his problem.
05.10.17 04:58:00 pm
Up
apex2d
User
Offline Off
Chill guys, maybe what he meant was the weird A symbol
Eat Sleep Conquer Repeat. www.Radeon2D.forumid.net
05.10.17 05:17:01 pm
Up
Masea
Super User
Offline Off
@user apex2d: That weird symbol or whatever it is, doesn't give an error output. And this one gives so it is definitely not. But nice try
Create and design your GUI easy and fast: file cs2d GUI Framework (v2) (11) | Go deep of the darkness and try your intrepidity: file cs2d Outlast 2 Modification (24)
06.10.17 04:24:03 pm
Up
ajm-sh
User
Offline Off
Mostly this issue prevails due to encoding probs.
Try to copy and paste the whole content to some other .lua file also use some decent txt editor.

Edit: stop using ftpclient's txt editor. Replace the whole file from your computer.
06.10.17 09:22:10 pm
Up
apex2d
User
Offline Off
@user Masea: well maybe, or is it the cs2d_dedicated?
Eat Sleep Conquer Repeat. www.Radeon2D.forumid.net
To the start Previous 1 Next To the start