English Tibia error : monsters don't die

9 replies
Goto Page
To the start Previous 1 Next To the start
Up
JamesBondBR
BANNED
Offline Off
I have downloaded Tibia rpg -FQ
and have a problem : the monsters don't die!
I open my server on dedicated but this does not work.
I hit the monster and he dont die.
ScreensShot:
http://imageshack.us/g/1/10282529/
or album

Console >
I'm pathetic. I like to destroy freeware games systematically. I think it's cool!
19.08.13 12:39:27 am
Up
Me Gusta
User
Offline Off
im help you send the lines with give the erro
19.08.13 07:29:03 am
Up
MikuAuahDark
User
Offline Off
then you may need to add this somewhere before the tibia lua

Code:
1
2
3
4
5
6
7
hudtxtalphafade=hudtxtalphafade or function(pl,id,ms,a)
     pl=pl or 0
     id=id or 0
     ms=ms or 0
     a=a or 1
     parse("hudtxtalphafade "..pl.." "..id.." "..ms.." "..a)
end

Reason: because i see from the error
Code:
1
LUA ERROR: sys/lua/cs2dtibia/monsters.lua:766: attempt to call global 'hudtxtalphafade' (a nil value)
it trying to call a function 'hudtxtalphafade' which does not exist. mosty can be caused by modified wrapper.lua
edited 1×, last 20.08.13 12:02:46 am
file cs2d LuaJIT for Dedicated Server (11) JIT POWER! | Know your Lua errors! | Draw stuff at Pixelize Art --xx-- server!
19.08.13 11:46:26 am
Up
EndDead
User
Offline Off
user JamesBondBR has written:
I have downloaded Tibia rpg -FQ

Contact the one who edited this tibia, its his fault. Or just post the whole script or the line with the problem
19.08.13 11:54:34 pm
Up
JamesBondBR
BANNED
Offline Off
In the console, he is saying that the error in this folder monsters.lua

I do not know where is the error, but this in that folder.

monsters.lua >


@user MikuAuahDark: where should I add it?
I'm pathetic. I like to destroy freeware games systematically. I think it's cool!
19.08.13 11:56:04 pm
Up
MikuAuahDark
User
Offline Off
try to add it after this
Code:
1
2
3
Monster = {name = 'Monster', health = 100, image = 'gfx/weiwen/circle.png', scalex = 1, scaley = 1, atk = 1, def = 1, spd = 5, x = 0, y = 0, ang = 0, imgang = 0, exp = 5, money = 50, type = 'monster', loot = {}}
MONSTERS = {}
local t = 0
file cs2d LuaJIT for Dedicated Server (11) JIT POWER! | Know your Lua errors! | Draw stuff at Pixelize Art --xx-- server!
20.08.13 12:04:11 am
Up
Me Gusta
User
Offline Off
can't see the error !?
20.08.13 12:08:25 am
Up
JamesBondBR
BANNED
Offline Off
Edit - I have download other wrapper.lua from cs2d.rip version. Now all is working.
edited 1×, last 20.08.13 12:24:43 am
I'm pathetic. I like to destroy freeware games systematically. I think it's cool!
18.10.13 11:04:14 am
Up
Varna97
User
Offline Off
i know why monsters dont die:
1) did you put wrapper.lua in sys/lua? [-Yes-] - No
2) did you deleted some commands ? [-Yes-] - No
i think you deleted hudtxt or something like this
thats why your tibia dont work
IMG:http://steamsignature.com/status/english/76561198124843516.png
18.10.13 09:07:38 pm
Up
JamesBondBR
BANNED
Offline Off
I have repaired this error. It was just to download another wrapper.lua
I'm pathetic. I like to destroy freeware games systematically. I think it's cool!
To the start Previous 1 Next To the start