English CS2D Beta 0.1.2.2

112 replies
Goto Page
To the start Previous 1 2 3 4 5 6 Next To the start
11.02.13 07:52:06 am
Up
knight-
User
Offline Off
------
edited 1×, last 11.02.13 12:58:36 pm

Admin/mod comment:

Please read the thread before posting blindly. Disable all lightengine related stuff. /DC
11.02.13 08:07:23 am
Up
Iceath
User
Offline Off
good work,dc

but i dont like the barricade as "obstacle".

can't you implent a new obstacle to building menu with wrench? maybe let barricade as WALL and make a new,something like "fence" or so?
11.02.13 08:31:23 am
Up
Don Captione
BANNED
Offline Off
Yes! I have no problem making my maps,thanks DC.Im gonna celebrate some cookiesIMG:http://www.unrealsoftware.de/img/cookies.gif
Blood skinning specialist
11.02.13 09:58:59 am
Up
RichNagel
User
Offline Off
user DC has written:
Unfortunately this happens on some systems. Including my own PC. I won't work on the lightengine as I didn't develop it myself. I recommend to disable all light and advanced shadow features in that case and to keep them disabled. Sorry.


Just a weird little thing though:

The previous version (Beta 0.1.2.1) didn't have any problems at all with the lighting engine on my PC. This newer version though requires me to totally disable lighting to prevent the game from crashing (either starting a game, or going into the editor), as others have posted.

Really a shame too... as the advanced lighting effects really looked nice.

P.S. The advanced shadows work fine... no lockups or crashes.


(EDIT/Addition) Another little change/problem that I've seen:

I use the ' key on my English keyboard as part of my custom keyboard control setup. From what I had previously determined, the " key on a German keyboard is the equivalent of the ' key on an English keyboard.

Hence, I previously used this binding

Code:
1
bind """ "buyammo2;weapon knife"


...which worked fine in the previous version of the game (when I pressed the ' key on my English keyboard).

In this newer version, the ' no longer works for me, and I see this in the console:

Code:
1
BIND: Can't bind! Invalid key ''!


That custom key binding also seems to somehow interfere with closing the main menu while in the new version of game. While playing the game, I press ESCAPE to bring up the menu, but pressing ESCAPE a second time doesn't close the menu.

If I remove the custom key binding, then ESCAPE closes the menu just fine.
edited 9×, last 11.02.13 11:10:14 am
11.02.13 11:07:40 am
Up
Well, I ain't updating mine until the next 2 days. Waiting for those weird bug fixes.
11.02.13 12:29:58 pm
Up
MikuAuahDark
User
Offline Off
It looks like that rcon are not working
I try this on my own server to test the color embedding with rcon command and it has no result.

EDIT: also i put correct RCon password(rcon_pw is correct)
Hello? Are you there, Tae Hanazono?
11.02.13 12:53:23 pm
Up
mafia_man
User
Offline Off
CS2D Dedicated Server:
IMG:http://img705.imageshack.us/img705/2628/asdrzn.jpg
11.02.13 12:55:59 pm
Up
Damn, those good servers aren't updated yet.
11.02.13 01:31:37 pm
Up
Lorenzz
User
Offline Off
I guess that you shouldn't have disabled the Lighting Engine, it was awesome!
Will it be back sometime?
I like to play CS2d,Sandbox games,and more
11.02.13 02:43:47 pm
Up
Starkkz
Moderator
Offline Off
I wonder if the "join" and "leave" hooks works for bots too in this version.
lol
11.02.13 02:56:54 pm
Up
uaiek
User
Offline Off
It seems to be good.
11.02.13 03:52:35 pm
Up
J_Lucas
User
Offline Off
with this version , i cant join , or create a new game , when i click new game , the cs2d stop works , crash , stop answer ,
why ?
i need help

Admin/mod comment:

Dude. Read the thread before posting. Disable light stuff. /DC
11.02.13 04:10:35 pm
Up
delicate
User
Offline Off
Why can't I join any server? The downloading screen appears with inscription "Scanning Entities" and nothing happens.
11.02.13 05:07:09 pm
Up
J_Lucas
User
Offline Off
user delicate , it was happens with me , but i fixed , i changed the particle details , when i downloaded the particle details is in "very high" , i changed to "medium"
11.02.13 06:14:48 pm
Up
Misho
User
Offline Off
I love Env_Sprite, Env_Image and Gen_FX.
Not that was hard to use them with x,y.
Great job.
11.02.13 08:31:08 pm
Up
SQ
Moderator
Offline Off
I have idea to write whole light thing when I get some free time.
11.02.13 08:36:59 pm
Up
Mechanic-GO
BANNED
Offline Off
My servers lua files stoped working.
Consoe: (LUA ERROR: sys/lua/mechanic/server:28: 'for' limit must be a number)
Ban reason: multi account of user Evaldas
11.02.13 09:28:10 pm
Up
maqL
User
Offline Off
USGN with MACBOOK problem,
in 122 version, usgn password dont is saved on menu...

Admin/mod comment:

Already reported. /Engi
12.02.13 09:15:57 am
Up
Adam-
User
Offline Off
Thank you for the CS2D Beta 0.1.2.2, DC!
Prehaps I can make some idea in CS2D Beta 0.1.2.3!


And :

Quote:
CS2D dedicated server

IMG:http://img705.imageshack.us/img705/2628/asdrzn.jpg


Soon, you must fix it, DC.
IMG:http://signaturecraft.us/avatars/10/body/DammyJummy3.png
Dummy Group
12.02.13 12:57:27 pm
Up
gotya2
GAME BANNED
Offline Off
user Adam- has written:
Thank you for the CS2D Beta 0.1.2.2, DC!
Prehaps I can make some idea in CS2D Beta 0.1.2.3!


And :

Quote:
CS2D dedicated server

IMG:http://img705.imageshack.us/img705/2628/asdrzn.jpg


Soon, you must fix it, DC.

I can confirm this bug on Windows 8 64 bit.
To the start Previous 1 2 3 4 5 6 Next To the start