English CS2D Bug Reports

1,840 replies
Goto Page
To the start Previous 1 2 ... 63 64 65 ... 92 93 Next To the start
16.11.17 03:28:05 am
Up
The Danel
User
Offline Off
user DC has written:
@user The Danel: Unfortunately this is a common problem. Of course there is no virus infection in the dedicated server. I assume it's detected as virus because it uses UDP sockets for network communication, writes files (logs) etc. These are suspicious things because malware would contain similar operations.

@user DC: i forgot
16.11.17 02:56:11 pm
Up
Medeiros
User
Offline Off
user DC has written:
@user Medeiros: You can edit the config file in sys/controls.cfg manually if nothing else helps (stop the game first). Weird issue though

I ended up just slowly but surely changing the controls by using the spamming 'fix' I mentioned.
Still was pretty annoying and I will be editing that file in the future if I ever need any adjustments to make the process faster.

user DC has written:
Regarding the key issues: I know that user SQ did some adjustments especially for the console key. Maybe he has an idea why there are problems or how to solve it. Might also be related to user Medeiros key assignment problem somehow.

Might be, as this is only happening to me on this version (1.0.0.5 Steam and Non-Steam).

I got the 1.0.0.4 version from http://www.unrealsoftware.de/get.php?get=cs2d_1004_setup.exe and I'm not getting the key assignment issue, the keys are immediately set to whatever I choose.
16.11.17 03:06:04 pm
Up
BcY
Reviewer
Offline Off
First, you login via Steam.
If you change your Steam nickname then try to open CS2D again, it will be failed to login.
Kgb2d Community - Since 2012
Up
Medeiros
User
Offline Off
I'm not getting any luck with this release, am I?
Now when I start CS2D, even though Steam shows I'm playing (and apparently my hours are counted on my profile) and • the game recognises my login, the Steam Overlay is not showing the Achievements, time played or any other info. It's not even unlocking achievements.
https://i.imgur.com/QgF3b4R.jpg

A clean re-install did nothing.
edited 1×, last 16.11.17 04:08:03 pm
16.11.17 03:55:48 pm
Up
Cure Pikachu
User
Offline Off
@user Medeiros: Maybe it's due to the custom Steam skin? (Mine looks fine, as seen here in 1080p) As for unlocking achievements, it just takes time to register, that's all.

Also, is it normal that the game always sorts the server list based on player numbers and will never save your sorting? (I personally like to sort servers based on latency)
IMG:https://i.imgur.com/uUrye71.png
IMG:https://i.imgur.com/xpsyQRX.png
16.11.17 04:02:09 pm
Up
Medeiros
User
Offline Off
user BcY has written:
First, you login via Steam.
If you change your Steam nickname then try to open CS2D again, it will be failed to login.

Yeap, I'm also getting this.
https://i.imgur.com/Tu0KvNG.jpg

It's fixed if you use the same name again that you first started CS2D with; which isn't the best thing.

user Cure Pikachu has written:
@user Medeiros: Maybe it's due to the custom Steam skin? (Mine looks fine, as seen here) As for unlocking achievements, it just takes time to register, that's all.

I would believe so if they weren't working the first time I opened CS2D. But they did, even remember that in the "so close" achievement box it listed the one where you simply lay a spray on the ground.

Also, I just checked my page and I did get an achievement, but it was last night and I think my overlay was working back then. Oh well.

--- Edit ---
Another thing, if I click on 'Guides' which should lead me to this: http://steamcommunity.com/app/666220/guides/, makes me go to http://steamcommunity.com/app/0/guides/ (which doesn't exist so it redirects to the home page). So I guess the problem is somehow connected to my Steam getting CS2D's AppID.

--- Edit 2 ---
Although my overlay is glitched, at least the hour and achievement tracking • is working. Still a shame it only works if I use the nickname I first started CS2D with it seems.
edited 1×, last 16.11.17 05:24:32 pm
17.11.17 07:13:37 pm
Up
VaiN
User
Offline Off
Linux client seg faults when trying to run in fullscreen mode. Includes the Steam and non-Steam versions. The only previous report I saw was related to missing libraries, but that doesn't seem to be the case here.

Quote:
$ sudo apt install libgtk2.0-0:i386 libidn11:i386 libglu1-mesa:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386

Reading package lists... Done
Building dependency tree
Reading state information... Done
libglu1-mesa:i386 is already the newest version (9.0.0-2.1).
libpangox-1.0-0:i386 is already the newest version (0.0.2-5).
libpangoxft-1.0-0:i386 is already the newest version (1.38.1-1).
libgtk2.0-0:i386 is already the newest version (2.24.30-1ubuntu1.16.04.2).
libidn11:i386 is already the newest version (1.32-3ubuntu1.2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded


I'm running Ubuntu 16.04 64-bit

The game runs fine in windowed mode, which is great for testing, but you can't play seriously in windowed mode.
17.11.17 08:28:19 pm
Up
Fraizeraust
Moderator
Offline Off
In non-Steam version of the Linux client the game gives no sound output despite OpenAL being the already chosen option as OpenAL is the only chance to get sound working. Also the Terminal displays some lines while launching the game via the command line. I believe there is nothing wrong from my side.
Code:
AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"
AL lib: (WW) alc_initconfig: Failed to initialize backend "alsa"
AL lib: (EE) ALCplaybackOSS_open: Could not open /dev/dsp: No such file or directory

@user VaiN: I also experience the same as you do (I use Linux Mint). The GNU Debugger reports the segfault occurs in
__libc_start_main
from
/lib/i386-linux-gnu/libc.so.6
along with the following weird lines though I doubt libc.so.6 really causes it.
17.11.17 08:32:39 pm
Up
DC
Admin
Offline Off
I guess I'll have to install a 64 bit Linux distribution in my VM to dig into these problems. Thank you for the feedback!
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
17.11.17 10:41:09 pm
Up
Reaper
User
Offline Off
user DC has written:
Regarding the key issues: I know that user SQ did some adjustments especially for the console key. Maybe he has an idea why there are problems or how to solve it. Might also be related to user Medeiros key assignment problem somehow.


I guess you may be right, shift 3 is still buggy for me, but now it opens the console instead of just stopping my movement. Have to check the options later.

//EDIT: Strange, I am sure my console key was ö yesterday and today it switched to conkey (^) as it used to be in previous versions.

When I switch the console key back to other options like ö or any other key, it is back to the old issue. (just stop moving with shift+3)

I guess you know it, but just to make sure, I am using a keyboard with the german qwertz layout. HyperX Alloy Elite MX brown, no manually installed drivers. Win10 ("austrian keyboard layout")

Just read: http://steamcommunity.com/app/666220/discussions/0/2425614361137244082/

switched it manually back to conkey using the config file, now shift+3 opens the console again.

Could it be that the key assignment was changed with 1005 p1
Code:
1
[FIXED] Key assignment in controls menu did not work properly


//EDIT: Fixed the bug for me, switched to english keyboard layout in Windows, everything is working fine with this setting.

Somehow I have an feeling the bug is connected to the tilde sign. Which is left to the 1 on the english and lithuanian keyboard @user SQ:

If I set the console hotkey to ö (which it was by default after installing the game via steam) it shows the tilde symbol in the settings menu.
edited 3×, last 17.11.17 11:11:25 pm
www.cs2d.me has launched - Join Now *CLOSED*
18.11.17 03:17:03 am
Up
SQ
Moderator
Offline Off
@user Reaper: Contact me on discord, we will fix it and I'll send you updated version to test it out.
18.11.17 12:01:48 pm
Up
_3yrus
User
Offline Off
in crowded servers(more than 20) sometimes scoreboards date goes over the screen !
here we go !
18.11.17 03:38:49 pm
Up
DiC
User
Offline Off
18.11.17 04:05:32 pm
Up
Fraizeraust
Moderator
Offline Off
Oddly in the Linux client, I cannot open the Console in-game with the ~ key. Changing it to conkey through control settings or controls.cfg works instead.
18.11.17 07:55:01 pm
Up
_3yrus
User
Offline Off
i found 4 bug in just about 1 day playing
my hp got 104 in jail server once when i collect bandage !
my hp was full but game showed it is 45 (i collect a medickit and i couldn't collect them anymore)
here we go !
18.11.17 08:35:44 pm
Up
-Francis
User
Offline Off
"my hp was full but game showed it is 45 (i collect a medickit and i couldn't collect them anymore)"

Yes, it happens to me too sometimes.
18.11.17 09:32:50 pm
Up
DiC
User
Offline Off
IMG:https://i.hizliresim.com/RON271.png


sad life
18.11.17 09:58:49 pm
Up
Yates
Reviewer
Offline Off
That's not a CS2D bug. That's Tibia not configured correctly for the new screen resolutions.
19.11.17 12:18:28 am
Up
Reaper
User
Offline Off
If you buy ammo, reload, and want to buy ammo again the game tells you that you can't. So you have to shoot one time and reload to be able to buy ammo again.
www.cs2d.me has launched - Join Now *CLOSED*
19.11.17 01:18:07 am
Up
Cure Pikachu
User
Offline Off
Some fonts don't change when I switch to languages that use a different font.
IMG:https://i.imgur.com/DNdCK2g.png

Notice the cs2d cmd say message font and the cs2d cmd hudtxt font is different.
IMG:https://i.imgur.com/uUrye71.png
IMG:https://i.imgur.com/xpsyQRX.png
To the start Previous 1 2 ... 63 64 65 ... 92 93 Next To the start