English CS2D Bug Reports

1,526 replies
Goto Page
To the start Previous 1 2 ... 74 75 76 77 Next To the start
28.07.18 12:41:49 am
Up
Hajt
User
Offline Off
user Hajt has written:
There is problem related with reqhttp/httpdata. If the request failed once then automatically the next requests also will not work...


https://pastebin.com/raw/dt9pbrTQ
Please have a look on logs, after 13:42:24 for some reason httpdata return empty results. To make it works again I need to restart the server...

It's gonna be fixed?
28.07.18 01:35:13 pm
Up
Edik
User
Offline Off
50% of people cant join because "can't join (failed to load map)"

i deleted myself all the files local and could download everything alright, but still half of people cant join. The logs dont tell me more than this simple error.

BTW. this is my 3th or 4th bug report, but i didnt got any feedback.
edited 1×, last 28.07.18 02:09:58 pm
28.07.18 02:54:36 pm
Up
DC
Admin
Offline Off
@user Edik: thanks for the report(s). We are aware of the map loading issue.
Please note that I do not respond to each individual report but I take all reports here into consideration and see if I can find and fix the reported issues!
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
29.07.18 02:53:44 pm
Up
Edik
User
Offline Off
@DC
is there any date when the failed map error will be fixed? Or if it will be fixed soon?
Because right now just a few people can join, and it feels bad to see how many want to join but cant.

If you need logs or infos, just tell me how I let the console show me more detailed Information, debug 2 doesnt do anything right now as far as I can see... i would contribute with my server if you need to test or reconstruct this error.
Hope it will be fixed as soon as possible
29.07.18 03:18:51 pm
Up
DC
Admin
Offline Off
No, sorry, there are no plans for the date of the next update and I'm currently not actively working on CS2D.
The problem can be avoided by playing on standard maps which don't need to be transferred.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
30.07.18 12:48:27 pm
Up
Edik
User
Offline Off
user DC has written:
The problem can be avoided by playing on standard maps which don't need to be transferred.

This is a pity
31.07.18 07:57:00 pm
Up
UnrealCS2Duser
User
Offline Off
user ohaz has written:
user Fraizeraust has written:
Code:
./CS2D: error while loading shared libraries: libsteam_api.so: cannot open shared object file: No such file or directory

This is the output I get when attempting to run CS2D via command line albeit the specific shared object
libsteam_api.so
file is already there in the folder. Copying the said SO file from other Steam games doesn't actually fix the problem. Note that I ran the standalone version of the game. My Linux distribution is Linux Mint 18.3 "Sylvia" 64-bit with a 4.13.0-38-generic version kernel.

The bug can be reproduced on the recent version -- 1.0.0.7 (thread news CS2D v1.0.0.7).
Does running "LD_LIBRARY_PATH=./:$LD_LIBRARY_PATH ./cs2d" work?


Hello, please, check steam post :c
https://steamcommunity.com/app/666220/discussions/1/1759104257585710112/
Any idea?
03.08.18 10:20:28 am
Up
DC
Admin
Offline Off
Sorry, no idea right now. If you only tried the standalone version you could give the Steam version a try.
Last resort would be to try the Windows client with Wine.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
Up
uaiek
User
Offline Off
On Linux, the game crashes when opening server list.
This also occurs when joining some server (with -j option). I can join server with 0 players or servers without steam players perfectly fine, perhaps it's a problem about loading other players' steam data?

Conditions
• Arch Linux
Linux resc 4.17.11-arch1 #1 SMP PREEMPT Sun Jul 29 10:11:16 UTC 2018 x86_64 GNU/Linux

• no steam (steam logo in the main page is red-crossed out)
• with USGN or without USGN logged in
• Graphics card: NVIDIA GTX 960M
• Network: WiFi
• Command line:
optirun ~/.steam/root/steamapps/common/CS2D/CS2D


Stacktrace
Code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
Signal: 11 (SEGV: segmentation fault)
#0  0x00000000f35b345f n/a (libnss_resolve.so.2)
#1  0x00000000f35bc04c n/a (libnss_resolve.so.2)
#2  0x00000000f35bdc5e n/a (libnss_resolve.so.2)
#3  0x00000000f35be797 n/a (libnss_resolve.so.2)
#4  0x00000000f35dc9c9 n/a (libnss_resolve.so.2)
#5  0x00000000f35c0868 _nss_resolve_gethostbyname3_r (libnss_resolve.so.2)
#6  0x00000000f35c0e4d _nss_resolve_gethostbyname_r (libnss_resolve.so.2)
#7  0x00000000f789b746 gethostbyname_r@@GLIBC_2.1.2 (libc.so.6)
#8  0x00000000f789ad0c gethostbyname (libc.so.6)
#9  0x00000000080d2809 n/a (/home/xxx/.local/share/Steam/steamapps/common/CS2D/CS2D)
#10 0x000000000828ed5f n/a (/home/xxx/.local/share/Steam/steamapps/common/CS2D/CS2D)
#11 0x000000000827c734 n/a (/home/xxx/.local/share/Steam/steamapps/common/CS2D/CS2D)
#12 0x0000000008225218 n/a (/home/xxx/.local/share/Steam/steamapps/common/CS2D/CS2D)
#13 0x0000000008209c03 n/a (/home/xxx/.local/share/Steam/steamapps/common/CS2D/CS2D)
#14 0x00000000082095cc n/a (/home/xxx/.local/share/Steam/steamapps/common/CS2D/CS2D)
#15 0x0000000008234fe2 n/a (/home/xxx/.local/share/Steam/steamapps/common/CS2D/CS2D)
#16 0x000000000819594d n/a (/home/xxx/.local/share/Steam/steamapps/common/CS2D/CS2D)
#17 0x00000000080e7a36 n/a (/home/xxx/.local/share/Steam/steamapps/common/CS2D/CS2D)


Why didn't I play from Steam?
• CS2D crashes immediately with MESA 18.1.5-1 (traced to i965_dri.so)
The workaround is to run it with discrete graphics card with tools like primusrun and optirun.
However, optirun the breaks the in-game steam overlay library because it uses virtualgl. And unfortunately, primusrun uses MESA. Even more unfortunate, steam automatically preloads its gameoverlayrenderer.so even disabling in-game overlay from the game's properties menu.

Another bug
I also observed that if steam_appid.txt exists (and valid) in the game's directory, the game will crash after the intro is finished.
It seems to be good.
05.08.18 04:00:46 pm
Up
DC
Admin
Offline Off
@user uaiek: You shouldn't run the game with a steam_appid.txt. That's for development purposes only. Not really a bug. The only legit way to run the Steam version is using Steam.

The other crash seems to be caused by failed DNS resolution. It's probably triggered when the game tries to download avatars. I'm not sure why it also happens in the server list because I'm currently not aware of any HTTP transfers (which trigger DNS resolution) in the server list itself.

Is there maybe a firewall or something like that which might prevent CS2D from doing proper DNS resolutions?

You can also try to set sb_avatars to 0 (options > more > scoreboard). That might help when you join directly via -j parameter or via quick play. It will disable avatar downloads.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
05.08.18 05:44:14 pm
Up
uaiek
User
Offline Off
@user DC: Thanks for sb_avatars workaround, I can now join the server but now the game just randomly crashed about a minute after joining the server. The stacktrace was the same and I don't have any firewall rules defined.

output of sudo iptables -S
Code:
1
2
3
-P INPUT ACCEPT
-P FORWARD ACCEPT
-P OUTPUT ACCEPT
It seems to be good.
05.08.18 06:39:05 pm
Up
DC
Admin
Offline Off
You may try to play without U.S.G.N. login and/or
-offline
parameter (disables U.S.G.N., playing online should still work). Unfortunately I have no idea why this problem occurs on your system so weird workarounds are the best thing I can offer at the moment.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
07.08.18 09:18:12 pm
Up
The_Admiral
User
Offline Off
Ent_Room does not cover walls, nor go over them.
It's about time i ditch this account, i've been hiding my identity for too long. I shall spread the news for the people of the Unrealsoftware Community to do the same. Join me, and together we may fight for a new future of the Community, Prevail.
07.08.18 10:51:01 pm
Up
Quattro
User
Offline Off
Please take a look at failed_load map bug... It pretty much breaks the game at the moment

Today I uploaded a new map, it worked for 3 guys at first but after several hours ~15 people tried to join at the same time and everyone got that error except us 3... And after that server crash
09.08.18 12:05:50 pm
Up
uaiek
User
Offline Off
user DC has written:
You may try to play without U.S.G.N. login and/or
-offline
parameter (disables U.S.G.N., playing online should still work). Unfortunately I have no idea why this problem occurs on your system so weird workarounds are the best thing I can offer at the moment.


Thanks, but
-offline
didn't help.

This could be a problem about library version. Perhaps linking CS2D statically in the next release will fix this.
It seems to be good.
13.08.18 11:29:48 am
Up
Quattro
User
Offline Off
@user DC:
Excuse me, but wouldn't it be an easy solution for "failed to load map tiles" bug, to make tiles force load? Every time you join a server it would check other files as normally but tiles would be downloaded and replaced without exception?

It just doesn't send tiles sometimes, tested it myself yesterday: all sprites get downloaded but it skips the tiles image and pops an error ">maptiles.format< could not be loaded". Of course it can't because there are no tiles in the folder
17.08.18 06:41:50 pm
Up
no u
User
Offline Off
Whenever I turn on CS2D and go to options, the startup screen shows up for about 5 seconds and then, whenever I try to change options or page, it doesn't work. It just stays on the player options. Pressing "Apply" or "Cancel" doesn't do anything. Pressing the X button does, however. I've had that glitch since I've installed CS2D.
"oi, fuckis"
17.08.18 08:00:12 pm
Up
DC
Admin
Offline Off
@user no u: Did you maybe install CS2D to a location where you do not have write permissions? e.g. "C:/program files/" or something like that?
I recommend trying to install it to a "neutral" location like "C:/cs2d" and/or to run it with admin permissions.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
19.08.18 10:08:51 am
Up
LiME1516
User
Offline Off
• Maybe someone already showed this bug.

There is an error in the "Buy menu" :

https://ibb.co/fiRGne
https://ibb.co/e40WLz
19.08.18 01:56:10 pm
Up
LoaderFRA
User
Offline Off
If cs2d cmd mp_buymenu (changed in server settings) have cs2d entity env_item id 56 (defuse kit), bots T can buy defuse kit and equip this
To the start Previous 1 2 ... 74 75 76 77 Next To the start