English CS2D Bug Reports

1,840 replies
Goto Page
To the start Previous 1 2 ... 44 45 46 ... 92 93 Next To the start
18.04.17 08:32:34 pm
Up
DC
Admin
Offline Off
@user Mami Tomoe: Thanks a lot for reporting. All of these problems are indeed caused by the new resolutions which are possible / by the system being designed only for a fixed 640x480 resolution.

Fixed the serverlist scrolling and the text line copy already. The editor seems to still have quite a big number of issues with resolutions which have borders.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
19.04.17 07:24:42 pm
Up
Starkkz
Moderator
Offline Off
Now that we're into the lua_pcall2 topic I wanted to mention that CS2D doesn't always show Lua syntax errors, so if you have a luaL_dofile2 function, you could make it check a luaL_loadfile and throw a simple error (with no stack trace).

If the luaL_loadfile works with no errors, perform a lua_pcall2 (with stack trace).

not the actual code (untested)
Code:
1
2
3
4
5
6
7
8
9
Function luaL_dofile2(L:Byte Ptr, File:String)
     If luaL_loadfile(L, File) <> 0 Then
          ' No stack trace
          Print "Error: " + lua_tostring(L, -1)
     Else
          ' Stack trace goes here
          lua_pcall2(L, 0, 0, 0)
     EndIf
EndFunction
lol
22.04.17 12:59:00 am
Up
Dictatus Papae
User
Offline Off
I've been going through the ai lua code and noticed that bots never respond to radio messages.

I found the problem in "Standard AI.lua", at line 392:
Code:
1
2
3
function ai_hear_radio(source,radio)
     fai_radio(source,id)
end


So, the radio id parameter is being passed to fai_radio simply as id.

The correct code is:
Code:
1
2
3
function ai_hear_radio(source,radio)
     fai_radio(source,radio)
end


Funny nobody noticed this so far.
22.04.17 01:00:57 am
Up
DC
Admin
Offline Off
lol
Thanks, will fix that.

Edit: actually already fixed here. Maybe didn't put the latest version of that in the release. Oooops.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
22.04.17 04:27:43 pm
Up
Andrez
User
Offline Off
Your bugs @user DC: :

advanced radar doesnt get modified by HUD color modifications
radar_red 255 for example

ANd nowwww.. after 10 years, i have the perfect example to show how ***** buggy is this little command "fow details"

IMG:http://i.imgur.com/msxF6gs.png


camera is just embarrasing the so "detailed fow" which is counter intuitive, and counter gameplay...

thats why no one on the competitive scene uses it. but on a large scale with this new camera i can show you easily.

Now something quite weird:
@user SQ:

on pre release 2:

On default menu you get the old crosshair on perfect scale, i mean its balanced(not so big, not so small).
But ingame you cant get it, even if you disable mp_recoil (which could be more intuitive as sv_recoil) it gets you to the new crosshair.

BUT on pre release 3.

You get a very fucking little old crosshair(which we all love) but it's so little that you cant play without recoil...

So: either leave it all to the new crosshair, OR MAKE the old one well scalled so we can play without recoil too.

Also knife's recoil when you move is very annoying.

And it would be good to pick a full config of recoil just like language, in game. Like mrc's one.
edited 3×, last 22.04.17 04:46:34 pm
∗ PCS ADMIN CS2D.NET - Clan: Storm . Cs2d competitive videos:Andréz
22.04.17 04:44:49 pm
Up
DC
Admin
Offline Off
@user Andrez: Both fog of war versions are calculated exactly the same way. You always see the same things. so players on the dark tiles would be hidden in both cases. Just the representation is different and single dark tiles are not visible in the smoothed fog of war representation.

So yes, for the most accurate representation of the fog of war you should always choose square cut.

Also that bug (dark tiles even though there is no obstacle) is caused by the increased range (which was just an experiment which will not be released in 1.0.0.3). This issue does not occur with the normal fixed camera.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
22.04.17 04:53:48 pm
Up
Andrez
User
Offline Off
Quote:
"does not occur on normal camera"
it happens a lot, but on a little scale, in little moments where it's very important. specially at close corners.
That's why i got this perfect image that shows it's buggy mecanism.


Quote:
Both fog of war versions are calculated exactly the same way. You always see the same things.


You will see how contradictory that is. You dont believe that yourself. You dont see the same things.
Quote:
you should always choose square cut
.
And well you said you see the same things but of course you say that we should use square cut

Then why it's not default? because the other one looks "better" but it's just counter intuitive, because as you said:
Quote:
players on the dark tiles would be hidden in both cases.

Those dark tiles you can only see them on square cut.


So the bug, is caused by the system which leads to a bad (intended?)representation which is observable both in normal camera and exaggerated in the new camera.
I dont know if it's a bug since you know about it, but it's a problem for newcomers, there's little chance that they would know that they are at a disadvantage. Anyways it's the least of the problems and i dont want you to spend time on it.

I hope you take it as constructive criticism.
Anyways, in case the new camera was released you can agree that it would be very important to know that detailed fow would be useless.

Anyways, you are right:
Quote:
Just the representation is different and single dark tiles are not visible in the smoothed fog of war representation.

My point was to inform people that they are always at disadvantage if they use detailed fow.
edited 2×, last 22.04.17 05:06:31 pm
∗ PCS ADMIN CS2D.NET - Clan: Storm . Cs2d competitive videos:Andréz
22.04.17 05:07:11 pm
Up
DC
Admin
Offline Off
I do take this as constructive criticism. Thank you. It's a serious problem if this also happens without the movable camera. We already adjusted the fog of war calculation precision for 1.0.0.3 because of the increased game resolution. For now we didn't spot any issues.

Why is smoothed FoW default? Because it looks better. CS2D's default settings are not optimized for hardcore pro gamers because these are a minority and they know how to adjust the game properly. They are optimized for casual gamers.

The smoothed FoW is definitely a compromise between look and precision. If you want max precision square cut is the only legit option because the underlying FoW calculation/precision is tile based.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
30.04.17 09:06:50 pm
Up
Mora_rus
User
Offline Off
I notice that in DM only for now.
When some1 using shield and you stay behind with any kind of weapon(except projectiles) and attack him - the hit won't be applied to him. but in front it would..
IMG:http://i.imgur.com/u1GRb7r.png
01.05.17 12:05:13 am
Up
Milriko
User
Offline Off
If you choose a resolution with black borders, this happens
IMG:http://pics.tinypic.pl/i/00897/xsf95vr9gryc.jpg


Basically you have an advantage over opponents. Shouldn't be able to see them ofc
I tested it on 1280x960. Ofc it's not proper for my screen.

PS. Also, idk if its just for me, if i choose a proper for my screen resolution, the whole in-game screen is turned 1cm into the left, so i cant rly see whats happening there and its just black on the right side.
IMG:http://imgupload.pl/images/46791184149161885069.png
01.05.17 01:03:18 am
Up
AtomKuh
User
Offline Off
My cs2d server on my vps just closed itself two times after some minutes. Do you have the same problem as well?
01.05.17 01:11:00 am
Up
edgard
User
Offline Off
I try to open a server with Lua, RPG Tibia, but I get something

LUA ERROR: sys/lua/cs2dtibia/server.lua:21 ´for´ limit must be a number
IMG:http://imagizer.imageshack.us/v2/280x200q90/661/AEtsl4.png
01.05.17 03:09:18 am
Up
BcY
Reviewer
Offline Off
"Mark Own Player" setting is not working correctly.
Kgb2d Community - Since 2012
01.05.17 06:00:19 am
Up
SQ
Moderator
Offline Off
user AtomKuh has written:
My cs2d server on my vps just closed itself two times after some minutes. Do you have the same problem as well?

There is one crash problem, something game process related with multiplayer in standard mode I guess. I'm trying to catch it and fix.

Edit: looks like replays feature actually made this issue, I have no idea how it managed to do that meanwhile being disabled.

@user BcY: Mark own player looks like working correctly, can you provide a screenshot?
01.05.17 06:19:09 am
Up
BcY
Reviewer
Offline Off
@user SQ: Sorry but i faced with that error once. If i see it again, i will post a SS.
Kgb2d Community - Since 2012
01.05.17 06:36:00 am
Up
SQ
Moderator
Offline Off
I already fixed that on my build. I think so. The mistake was quite stupid. Oh it seems there is another one.
01.05.17 06:51:27 am
Up
Yu
User
Offline Off
-Menu command is bugged
+Objects
+Npcs (Maybe because of resolution, but i think npcs should attack on sight)
https://youtu.be/V295shx0MLA
01.05.17 07:07:13 am
Up
MikuAuahDark
User
Offline Off
Using 1136x640 resolution (technically 16:9)

IMG:http://i.imgur.com/6npSQUa.jpg
file cs2d LuaJIT for Dedicated Server (11) JIT POWER! | Know your Lua errors! | Draw stuff at Pixelize Art --xx-- server!
01.05.17 11:07:50 am
Up
VADemon
User
Offline Off
Imo this needs to be fixed prior to Steam release:
Chat message hotkey: Must default to Y, not Z on QWERTY keyboards
Console hotkey: Must default to ~, not "conkey" on QWERTY keyboards

---

Client to Server connection bug with USGN accounts, 1.0.0.2 and 1.0.0.3: https://youtu.be/RBPv-jRHj10
• Start a server
• Start client with USGN from commandline with -j localhost parameter to join the server
° Client without USGN connects instantly, no bug here
• The client will not connect to server or receive a timeout although the server didn't accept the join request because USGN was not verified
> Problem with -j localhost
> If the verification didn't work at server-side, the client must receive a CONNREFUSED message/timeout

Edit:
If the server address is written as "127.0.0.1" then the user will not pass verification
However if you join via LAN or specify the IP as your local LAN IP (192.168.0.2 in my case) - the verification will work normally.

Console Log, there ARE problems with USGN verification >
01.05.17 11:51:44 am
Up
DC
Admin
Offline Off
@user VADemon: Thanks for reporting. I'm already aware of this issue. This is caused by WAN vs LAN IPs. Luckily running a server and a client on the same machine is not a common real word scenario. You should normally run a listen server (just use the client and "new game") in this case.

@All the other issues: Thank you very much guys for reporting the stuff. I will release a silent hotfix (without version increase) to address some of the worst issues. Will let you know about it here.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
To the start Previous 1 2 ... 44 45 46 ... 92 93 Next To the start